Wy mono sound since ep17 ?

Install, MegaRanger!
Forum rules
Wiki Link

< DaiRanger | MegaRanger | TimeRanger >
User avatar
GeJe
It's not even funny
It's not even funny
Posts: 12
Joined: Sun Mar 15, 2009 4:05 pm
Male: Yes
Favorite series: Sentaï

Wy mono sound since ep17 ?

Post by GeJe » Sun Jan 01, 2012 8:18 am

Hi eveyone,

I was surprised by the good stereo and PLII effects on this show.
Any reason why MegaRanger is in mono since episode 17 ?

Anyway I am really enjoying all the sentaï offered by T-N, and I just wanted to thank all of the team for their work. That’s done. Combo.

User avatar
XIII
The Conspiracy
Posts: 5531
Joined: Tue Dec 18, 2007 12:10 pm
Male: Yes
Favorite series: Garo
2nd Favorite Series: KR Faiz - Kab
Alignment: Chaotic Evil
My boom: Devil Z
Location: UK

Re: Wy mono sound since ep17 ?

Post by XIII » Sun Jan 01, 2012 8:21 am

because MegaRanger was aired with mono-sound, it wasn't till that ep when we realised that it was, so we made the change as such
Live for the Moment, for the Moment is Eternal!

User avatar
takenoko
Team Baron
Team Baron
Posts: 28955
Joined: Mon Dec 10, 2007 8:33 pm
Male: Yes
Favorite series: All of them
Alignment: Neutral
My boom: stick
Quote: "Are you the new monarch, or are you just a pawn of fate?" - Emerald Herald
Type: ISFJ Protector
Location: Yami ni umare, yami ni kisu
Contact:

Re: Wy mono sound since ep17 ?

Post by takenoko » Sun Jan 01, 2012 8:57 am

I don't know what you're hearing, but it definitely ain't stereo.
Image

All the old Sentai we do, Zyu, Dai, Mega should be in mono since there's only one audio track. Keeping it in stereo would waste space since it's a duplicate track.

User avatar
GeJe
It's not even funny
It's not even funny
Posts: 12
Joined: Sun Mar 15, 2009 4:05 pm
Male: Yes
Favorite series: Sentaï

Re: Wy mono sound since ep17 ?

Post by GeJe » Mon Jan 02, 2012 1:58 am

What I was hearing was my AV receiver conversion to 7.1 surround ! I wasn’t aware it was able do this on mono sound, so I get fooled by it, until I saw the “mono” logo on Plex…

Thanks you both for answering, keep the great work on !

User avatar
takenoko
Team Baron
Team Baron
Posts: 28955
Joined: Mon Dec 10, 2007 8:33 pm
Male: Yes
Favorite series: All of them
Alignment: Neutral
My boom: stick
Quote: "Are you the new monarch, or are you just a pawn of fate?" - Emerald Herald
Type: ISFJ Protector
Location: Yami ni umare, yami ni kisu
Contact:

Re: Wy mono sound since ep17 ?

Post by takenoko » Mon Jan 02, 2012 2:13 am

That's pretty amazing that it can do the conversion like that. I've heard of some systems that can emulate it, but didn't know they could do it from a single track!

I'm just amazed you noticed it. It was an interesting question to say the least.

User avatar
GeJe
It's not even funny
It's not even funny
Posts: 12
Joined: Sun Mar 15, 2009 4:05 pm
Male: Yes
Favorite series: Sentaï

Re: Wy mono sound since ep17 ?

Post by GeJe » Mon Jan 02, 2012 2:46 am

I am as amazed as you are ! Actually, I love the sentaï opening where the “choir” yells “Denji Sentaï” and the loud male voice continues with “MegaRanger”. There, the “choir” is heard in the surround channels and the single voice in the front center (dialog) channel only.
So that’s not true stereo panning for sure, but well done sound spacialization (the subwoofer is working great for explosions and GalaxyMega).
I use ProLogic IIx (x=extended to 7.1) or NeuralTHX7.1 codecs for these show.

I have just checked with the opening of ep3 vs ep20 : what I can tell for sure is that since the sound is flagged mono, I don't these effects anymore, it’s really flat, only in the front channels.
Should you keep the stereo where it’s not, I can’t tell, I can only say that makes a difference to me… And it explains why I was perceiving something different for some time !

User avatar
takenoko
Team Baron
Team Baron
Posts: 28955
Joined: Mon Dec 10, 2007 8:33 pm
Male: Yes
Favorite series: All of them
Alignment: Neutral
My boom: stick
Quote: "Are you the new monarch, or are you just a pawn of fate?" - Emerald Herald
Type: ISFJ Protector
Location: Yami ni umare, yami ni kisu
Contact:

Re: Wy mono sound since ep17 ?

Post by takenoko » Mon Jan 02, 2012 3:01 am

I'm sure it'd be pretty easy to to fake the stereo.

If you have the lame audio codec installed, you can just open the file in Virtualdub set the following settings, and reencode the audio to stereo:
Video->Direct Stream
Audio->Full Processing
Conversion->Stereo
Compression->Lame MP3->48000 hz 128 kbps cbr stereo

Or you can export the audio and convert it with Audacity or something, then direct stream the audio back in.

User avatar
GeJe
It's not even funny
It's not even funny
Posts: 12
Joined: Sun Mar 15, 2009 4:05 pm
Male: Yes
Favorite series: Sentaï

Re: Wy mono sound since ep17 ?

Post by GeJe » Mon Jan 02, 2012 3:36 am

Thanks you for taking care to give me a way to get back stereo.
Actually I am on a Mac Pro, it should be easy to do too with only QuickTime 7 Pro (extract audio track, export track to MP3 stereo, paste on movie, save)

And you’re right : if the source is not stereo, the encode shouldn’t be.

User avatar
GeJe
It's not even funny
It's not even funny
Posts: 12
Joined: Sun Mar 15, 2009 4:05 pm
Male: Yes
Favorite series: Sentaï

Re: Wy mono sound since ep17 ?

Post by GeJe » Mon Jan 02, 2012 4:27 am

A follow-up : it’s not the solution. Maybe not the problem.
I’ve just tried it : convert a mono track to 320Kbps stereo MP4 audio. I only gain a little bass from the subwoofer, but no spacialization at all.
Actually, when using QuickTime in reading all the movies simultaneously (I have only the audio of the active window I click on), I can compare audio with synchronization on all movies, against my extracted and converted audio track.
It sounds like there is a “low pass filter” on the mono track, staying there with the stereo conversion. The pseudo-stereo tracks you encoded in ep1 to 16 sounds brighter, like a “high pass filter”, and spacialize correctly.
This has certainly something to do with the way LameMP3 is handling audio.

Something surprising though : I looked at the audio stream with media inspector, here are the results :
This is for ep1-16 :

Code: Select all

Audio Stream #1
  Codec.............................................MPEG Audio
  Codec (FourCC)....................................55
  Codec Profile.....................................Joint stereo
  Audio Stream Length...............................24mn 24s 403ms
  Audio Stream BitRate..............................128 Kbps
  Audio Stream BitRate Mode.........................CBR
  Number of Audio Channels..........................2
  Sampling Rate.....................................48.0 KHz
  Audio Stream Size.................................22.3 MiB (10%)
  Audio Encoder.....................................LAME3.95
And since ep17 :

Code: Select all

Audio Stream #1
  Codec.............................................MPEG Audio
  Codec (FourCC)....................................55
  Audio Stream Length...............................24mn 27s 423ms
  Audio Stream BitRate..............................128 Kbps
  Audio Stream BitRate Mode.........................CBR
  Number of Audio Channels..........................1
  Sampling Rate.....................................48.0 KHz
  Audio Stream Size.................................22.4 MiB (9%)
  Audio Encoder.....................................LAME3.95
Audio size is actually the same size be it mono or stereo sound ! Probably the result of MP3’s joint stereo.

I’ll try to add a filter to the mono sound to see if I can get it sound as the pseudo-stereo you encoded.

User avatar
takenoko
Team Baron
Team Baron
Posts: 28955
Joined: Mon Dec 10, 2007 8:33 pm
Male: Yes
Favorite series: All of them
Alignment: Neutral
My boom: stick
Quote: "Are you the new monarch, or are you just a pawn of fate?" - Emerald Herald
Type: ISFJ Protector
Location: Yami ni umare, yami ni kisu
Contact:

Re: Wy mono sound since ep17 ?

Post by takenoko » Mon Jan 02, 2012 4:53 am

That's weird. Besides running it through a normalization filter, I really don't do anything else with the audio. When I tested it, the audio size for stereo was 18 mb and for mono was 9 mb.

Edit
Just did another test.
If I encode stereo or mono at 128 kbps, they're both 18.2 mb. If I encode mono at 64 kbps, it's 9.14 mb.

User avatar
GeJe
It's not even funny
It's not even funny
Posts: 12
Joined: Sun Mar 15, 2009 4:05 pm
Male: Yes
Favorite series: Sentaï

Re: Wy mono sound since ep17 ?

Post by GeJe » Mon Jan 02, 2012 7:35 am

That’s logical (Spock, are you there ?!) : joint stereo only encode differences in L&R channels, so you’ll have the same size at the same bitrate, and half at half bitrate.
I don’t know why the episodes went from 19mins to 24mins, that’s why you have about 18,2MB instead of about 22MB.

I looked at the sound waves and they do look different : the mono is “flatter” than the pseudo-stereo :
Stereo
Image
Mono
Image

So maybe the normalization filter is doing something unexpected ?

(One thing, out of context : I just purchased the DVD box set for Chōdenshi Bioman with the japanese original track. If it could be of interest to you I’d gladly share them (I don’t know if they are available elsewhere because Bioman was very special to french audience))

User avatar
takenoko
Team Baron
Team Baron
Posts: 28955
Joined: Mon Dec 10, 2007 8:33 pm
Male: Yes
Favorite series: All of them
Alignment: Neutral
My boom: stick
Quote: "Are you the new monarch, or are you just a pawn of fate?" - Emerald Herald
Type: ISFJ Protector
Location: Yami ni umare, yami ni kisu
Contact:

Re: Wy mono sound since ep17 ?

Post by takenoko » Mon Jan 02, 2012 7:44 am

I typically normalize all the audio, so both examples should be normalized the same. The source audio from the DVD has two tracks. It's not converted to mono until the encode process.

Is it worth mentioning that stereo is encoded at 128 kbps and mono is at 64 kbps? I don't think that would make the actual peaks and troughs bigger or smaller though.

I mean, is it possible that the audios that you're looking at just happen to be louder in one instance and more quiet in the other?

User avatar
GeJe
It's not even funny
It's not even funny
Posts: 12
Joined: Sun Mar 15, 2009 4:05 pm
Male: Yes
Favorite series: Sentaï

Re: Wy mono sound since ep17 ?

Post by GeJe » Wed Jan 04, 2012 3:42 pm

Thanks you for getting back to me.

I’ll try to see if I set the volume at the same level for both tracks I get the same results, but I doubt it, there is really a noticeable difference in the “shape" of the sound.
It’s different indeed to encode at 128Kbps rather than 64kbps, and probably it’s the cause of the audio change.
But what I don’t get : you told me that you have encoded mono at 64kpbs but it’s still 128kpbs in the final release ?
If at one time the pseudo-stereo at 128kbps is converted to 64kpbs, there is a loss in quality.

Do you have the original audio for me to run some tests ?

(BTW you haven't seen or answered my (out-of-context I admit) offer for Bioman in the end of my previous post)

User avatar
takenoko
Team Baron
Team Baron
Posts: 28955
Joined: Mon Dec 10, 2007 8:33 pm
Male: Yes
Favorite series: All of them
Alignment: Neutral
My boom: stick
Quote: "Are you the new monarch, or are you just a pawn of fate?" - Emerald Herald
Type: ISFJ Protector
Location: Yami ni umare, yami ni kisu
Contact:

Re: Wy mono sound since ep17 ?

Post by takenoko » Wed Jan 04, 2012 3:47 pm

The original audio is whatever was on the DVD. I usually encode stereo at 128 kbps, so I figured that if I take out a channel, I could get away with encoding it at 64 kbps. Otherwise there's no point in dropping the second stream if there's no space saving thing.

Ah, sorry about missing the other question. I nearly did it again. I really don't see us doing another Sentai series any time soon.

User avatar
GeJe
It's not even funny
It's not even funny
Posts: 12
Joined: Sun Mar 15, 2009 4:05 pm
Male: Yes
Favorite series: Sentaï

Re: Wy mono sound since ep17 ?

Post by GeJe » Sun Jan 08, 2012 8:45 am

So the problem is with normalization or encoding bandwidth.
Any chance you could try an encode without normalization to see if the sound gains it’s original relief back?

No problem for the second question, and I fully understand how full your planning is ! BTW just went to http://www.toei-video.co.jp/DVD/sp21/supersentai.html, looks like a lot of work is ahead !

Post Reply

Return to “Sentai-Denji Sentai MegaRanger”